Terrible Image quality in build

Hi, I have terrible image quality for all textures in build, vs when started local from unity. I spent hours trying to configure textures, nothing seems to have any effect. Can you please help ? I can’t make the customer satisfied :frowning_with_open_mouth: Here are images of build vs local and texture settings. Which compression type and or setting gets me the 1 to 1 result of the image ?

Original Post on Discord

by user 606919514772340737

oh, and Iam using quads with unlit material

by user 606919514772340737

Are you making production builds? Have you tried making a dev build?

yes Iam making production builds, didn’t tried dev build. gonna do it now.

by user 606919514772340737

oh…ok dev build fixes it. thanks :slightly_smiling_face:

by user 606919514772340737

When you make production builds images (and meshes) in the glb get compressed which is usually great for filesize and “regular” textures but in your case with vector graphics that compression doesnt work well - we will allow setting compression settings from Unity in a future update (to e.g. exclude certain images from being compressed or better controlling which compression is being applied) but right now that’s not fully available yet

thanks for the clarification. I guess I’ll be fine with dev build :slightly_smiling_face:

by user 606919514772340737

Agreed, etc1s doesn’t look good on those images :eyes:
I’ll make sure we have a similar type of image in our test scenes when we implement per-texture compression

Also worth noting that it’s a good idea to set the import compression in Unity’s texture importer to “No compression” to avoid double compression in our pipeline (we’re looking at streamlining this more)

Compression options would be huge, on my first Needle project, the client wanted some images changed quite close to the deadline and I had to deliver a dev build instead because we couldn’t achieve the desired look while using compression in Production builds

by user 103054507105067008