AR reticle slow to appear

Right… good call with the Bike Demo @ROBYER1!

Tried it a few minutes ago and my device behaved exactly as it has been with everything else… i.e. no reticle.

However!!! I remembered that I had an old (five years or thereabouts) Huawei P20 Lite gathering dust in a cupboard here somewhere, so I managed to dig it out and charge it up… and the first thing I tried on it as soon a there was enough charge (and the OS had updated) was the bike demo you’ve linked to.

Hey presto… instant reticle and instant (and perfect) placement of the bike in AR :raised_hands:

So, the great news is, it’s not a Needle issue at all and that of the two devices I’ve now tested with it’s my newer, Motorola G9 Power that’s garbage.

Of course, the bad news is… that it’s my newer, Motorola G9 Power that’s garbage :neutral_face: :stuck_out_tongue_winking_eye:

by user 908977119781060648

There can be some really inconsistent devices for ARCore I have found in the past, happy to help! Worth marking this post as answered :slightly_smiling_face:

by user 103054507105067008

Thanks for testing that as well! Did the Bike Configurator also take so long on your Moto G9?

Yep, @herbst🌵… as per my previous response, I tried the bike demo on the Moto G9 before I tried the old P20 Lite, and the G9 didn’t display a reticle at all.

by user 908977119781060648

The bike was in fact developed and tested using a Huawei P20 :sweat_smile: until it died

Ah, missed that part in your text, thanks frannie

No worries :slightly_smiling_face:

Huge thanks everyone, for all your help. It’s been much appreciated! :heart:

So, now all I have to do is find out how to mark this as answered :sweat_smile:

by user 908977119781060648


found the tag :grinning:

by user 908977119781060648

Just a quick update for additional info…

I eventually became so annoyed with my Moto G9’s intransigence when it comes to running any AR Needle projects that I performed a full factory reset on it to see if that would make a difference.

With everything updated (namely the latest v of the OS and Google Play Services), but with nothing else installed on the device other than the following browsers, I ran the previously mentioned tests using Chrome and Firefox.

/ / /

CHROME RESULTS
model-viewer demo: The model loaded and the AR button was present. When clicked, the camera view opened and a plane was immediately found and the model was placed in AR.

Needle Tools Test Projects: The projects loaded and the ‘AR/VR’ buttons were there onscreen, but when an attempt to run the AR was made nothing happened. A white screen flashed up briefly, followed by the camera view launching, but no reticle ever appeared despite extensive panning and waiting.

FIREFOX RESULTS
model-viewer demo: The model loaded but no AR button was present.

Needle Tools Test Projects: The projects loaded but the ‘AR/VR’ buttons both displayed the words ‘WEBXR NOT AVAILABLE’. When either were clicked I was taken to https://immersiveweb.dev/

/ / /

Once again all the tests ran perfectly on a very old Huawei P20 Lite… but very definitely no joy from the Moto.

So, I think we can probably consider the Motorola G9 Power a no-go when it comes to this stuff.

[memo to self: time to look for a new phone :grimacing: ]

by user 908977119781060648

Thanks for that elaborate test! One possibility is that we’re requesting additional features that model-viewer is not requesting for immersive-ar, and that your phone goes into a “bad mode” when those features are requested but not when only the features model-viewer requests are.

You can test this too if you want - when you look into the WebXR.ts script and the ARButton.js script you can see which features are requested when starting the session, and can try turning some of them off again to check if that changes the behaviour (there’s no exposed way right now of doing that, need to mess with the core)

Oooooo, cheers for that suggestion! I’ll give that a go and see what happens (I’m too fascinated to stop now :sweat_smile: ).

I’ll report back asap :+1:

by user 908977119781060648

Okay, so I randomly (really, really randomly!) began by commenting out some of the imports in WebXR.ts to the point whereby the only thing that ran in Glitch was a black screen.

Then I uncommented the same stuff, ran it again… and hey presto, it worked :thinking: … and I have literally no idea why???

The reticle was very slow to appear (and seemed very flakey/jittery and hard to position) but it was there nonetheless… and, when tapped, the AR content was placed as expected.

So… I’m no wiser but at least I’m able to run projects on the Moto G9 now, so I’m savouring the ‘victory’ :slightly_smiling_face:

by user 908977119781060648

Haha, ok - do you know if there is still something changed in the code? Would be weird if you rolled everything back and behaviour changed

It’s really baffling, isn’t it? There’s definitely nothing changed in the code.

I literally just removed the ‘commenting out’ that I’d introduced; then resaved it, rebuilt it and deployed it again… and there it was… a functioning reticle.

Most odd!

by user 908977119781060648