VR/SpatialMapping/Occlusion shader not exporting correctly

Hi, I just realized, that the VR/SpatialMapping/Occlusion Unity shader doesn’t export correctly to three. While I know that this is not a trivial thing in three.js (colorWrite, renderOrder), just wanted to point it out here :slightly_smiling_face:

best regards,

Original Post on Discord

by user 474974683163394049

Ah, this a shader that ships with Unity right? You can take a look at the ShadowCatcher sample / materials, you should be able to modify that to just be a depth blocker.

Thx will try that :slightly_smiling_face:

by user 474974683163394049

Next version will have “Occluder” as additional rendering option on ShadowCatcher - not ideal but a start :slightly_smiling_face: