Vertex colors option

Why does the vertex colors export to the browser even tho I unchecked the option on unity?

Original Post on Discord

by user 483253293477265409

This has been asked before, please try to search first before asking :slightly_smiling_face: Discord

but idk why in my 3d editor the vertex colors don’t look like that

by user 483253293477265409

What do you mean with your 3d editor?

cc @herbst🌵

I agree this can be a bit confusing.

In glTF there is no concept of “this mesh has vertex colors BUT they aren’t displayed” - if a mesh has vertex colors they are always displayed.

That’s why the material inspector in Unity shows you a :warning: Warning when you’re disabling vertex colors but the mesh has them:

I’m just assuming it is the vertex colors because I unchecked that option and the material was shoeing fine on unity and if I left it checked then the mesh turned black as it happens on runtime. but then again idk why the mesh has color itself, I think no one painted over it but idk how to check it since maya is not showing anything on the mesh

by user 483253293477265409

If you select the mesh in Project window you can check it in Unity

It looks like it has

by user 483253293477265409

Yeah, then you’ll probably have to find the setting in Maya to either remove it or exclude it from export