Struggling with materials

Hi! I’m a Blender user, but I downloaded Unity to to play with Needle and while I can get a scene up and running, import my model and set up lighting how I’d like, I’m struggling to make materials/shaders work.

Since I’m unfamiliar with Unity I’m finding the documentation difficult to understand. My Blender materials don’t import as expected, but having removed them and tried to build PBR materials using Shader Graph the Server (after updating) still shows the default white material.

Could anyone help? Also I think some introductory ‘lay-person’ style tutorials for smooth brains like me would be really beneficial!


Original Post on Discord

by user 911725080952832010

So first things first, Needle Engine is also available for Blender :slightly_smiling_face:

That being said, the best way to bring proper PBR materials and lighting over from Blender to Unity is via .glb / .gltf file format

When you set up materials in Unity, we recommend you use Universal Render Pipeline and URP/Lit or UnityGLTF/PBRGraph materials for full PBR support – custom shaders aren’t necessary unless you know what you’re doing

thanks! I saw it was in blender but the feature set isn’t fully operational if I’m correct?

So I think I have created Lit materials but they’re not showing in the live preview, where I can see them working in Unity

by user 911725080952832010

You mean URP/Lit with textures assigned and so on? And it looks correct in Unity?

OK I noticed project Graphics settings were HDRP so I have now installed and switched it to URP.

What I’m doing is creating an asset Material which has a default Shader of HDRP/Lit and changing the Base Map to a colour to see if it is working. That looks correct in Unity but not on local server preview. If I change the Shader setting to URP/Lit, Unity shows a magenta material no matter what.

From a little research it looks like I’ve set my project up incorrectly but also some known issue with URP materials in Unity… I will keep looking and try to fix

by user 911725080952832010

thanks for your help!

by user 911725080952832010

From what I can tell rebuilding as URP from the start has fixed it :slightly_smiling_face:

by user 911725080952832010

I see - thanks for letting me know :slightly_smiling_face:
Interesting that HDRP didn’t work - we haven’t done extensive testing on that but in principle it should. Will check!