Shadow on ground but now onto mesh sitting on the ground?

Anyone know how to make it so that I have more accurate shadows from ground and some onto the sides of a mesh?

Because the way it looks now, the meshes look like they are “floating” above the ground plane.

(cube with green ground plane = bad)

Using Unity 2021.3.19f1.
image.png
image.png

Original Post on Discord

by user 276719669878980608

Changed the channel name: Shadow on ground but now onto mesh sitting on the ground?

by user 276719669878980608

You can try with screen space ambient occlusion. It’s not built-in, but seems to be possible: Discord

by user 395602247196737546

Or you could bake the shading into your cube’s texture. I don’t think dynamic lighting can give you the effect you’re looking for (and that’s why there are realtime trickeries like AO).

by user 395602247196737546

You can also tune the shadow bias and offset settings, that will help. It’s scene specific (so the defaults can work well or not depending on your scene)

Thanks @krizzl0r, @herbst🌵. I’ll give it a go this weekend.

by user 276719669878980608