Predetermining the Scale of AR Content (to create similar sizes across both WebXR and Quicklook)

Hi all :wave: :slightly_smiling_face:

Is there a way to preset the initial launch scale (if that’s the right way to phrase it?) of content that’s been created using the USDZ Exporter and which is being viewed in AR?

When I use ‘WebXR Session Root’ to set the ‘AR Scale’ that I’d like content to be shown at in relation to the user (0.5 for the project I’m currently working on), the content is shown at exactly the size I want when viewed in WebXR AR. However, if a user is viewing the same content on iOS courtesy of the ‘Quicklook’ version that’s generated by ‘USDZ Exporter’, the disparity between the size of that version and the WebXR version is quite significant.

The initial AR scale of the Quicklook version is enormous. Really HUGE. In fact, in order for the Quicklook version to display in a user’s world space at the same kind of scale as the WebXR version it needs to be manually manipulated (with some difficulty, via pinch and zoom) down to circa 10% of its initial launch size.

So I was wondering if there’s there’s a way that I can set something somewhere to ensure that the USDZ version of the content will launch at 10% of its actual scale? Or maybe there’s a better solution?

Or, perhaps I’m on the wrong track here altogether with all this and I need to re-examine the scaling of my original .glb models when making them? :thought_balloon:

I’d be very grateful for any thoughts, feedback or suggested fixes.

Cheeeeeeeeeeeeeeers, in advance, for your time and expertise :smiling_face_with_three_hearts:

Original Post on Discord

by user 908977119781060648

Hi there!

Do you have an WebARSessionRoot in your scene and is your content parented to that? We’re applying the scaling of that to the scene also for QuickLook.
The idea is that you don’t have to manually think about sizing and instead WebARSessionRoot ensures that scale is the same for WebXR and USDZ - if objects are parented to it

Ah, possibly not. Cheers for that @herbst​:cactus: :slightly_smiling_face: I’ll certainly check how I’ve got things set up asap.

I’m away from my desk for a couple of hours but will feedback here as soon as I’ve had a fresh look at it all.

by user 908977119781060648

Huge apologies for the delayed comeback (I had to spend yesterday affecting some much overdue computer maintenance :grimacing: ).

So, I have my project set up as shown in the screenshot here. There’s no USDZ Exporter being used in this version (as the results were too large, as mentioned) but hopefully the shot indicates that the WebARSessionRoot and object parenting is set up as it should be?

by user 908977119781060648

by user 908977119781060648

Where did you place the USDZExporter before? And did it have the same root assigned?

I had it set up like this…

by user 908977119781060648

by user 908977119781060648

I think you just need to assign Content instead so that the WebARSessionRoot is applied

My guess would be that „handyhat“ is scaled by a lot?

I think it’s scaled a fair bit, yep.

I’ll definitely try assigning Content instead, though. Many thanks for the advice @herbst​:cactus: … I’ll give that a try right now and feedback asap :slightly_smiling_face:

by user 908977119781060648

Yes please do! I’ll also check if we maybe don’t apply the root scale of the assigned object correctly in your case

Hmmmmm… sadly no luck. I ran things as per your suggestion, and have also tried a few other variations on that set up too, but when the USDZExporter is applied to ‘Content’ the Quicklook button that’s generated doesn’t seem to work at all.

A Quicklook button is successfully displayed onscreen (I’m testing using an iPad Pro) but it’s non-functional and doesn’t do anything when clicked.

No worries. I’ll keep trying other combinations and will feedback here if I hit on something that’s a goer :slightly_smiling_face:

by user 908977119781060648

Would you mind sending the scene as bug report? Thanks!

It’s on its way to you now, flagged as ‘F.A.O. @herbst​:cactus:’. It’s not a very tidy project but hopefully you’ll be able to see what’s what :slightly_smiling_face: Just shout if anything doesn’t make sense.

The USDZExporter currently has ‘Content’ assigned to it (which is the set up which doesn’t seem to work).

Huge thanks for looking into this. It’s greatly appreciated!!! :smiling_face_with_three_hearts:

by user 908977119781060648