Grey Screen after starting local server

This started on another machine for me, so I switched back to my main computer and loaded an older project.

Everything was working fine until I updated Needle to 3.32.5. I get this grey screen when launching the project. I’ve tried downgrading to 3.32.4 and get the same thing, I’ll try downgrading a few more times but I’m not sure where to go after that.

I’ve tried new projects, different computers, different browsers - I’m running Unity 2022.3.14f1

Original Post on Discord

by user 507643794963824650

Hello there – we have an experimental AI bot :robot: that might be able to help you with your question. Would you like to try this out?

How it works:
Reply to the messages of the bot that end with a thread_id to interact with it and ask follow-up questions. You can also mention the bot directly in this channel to get help.

Help requested: please wait a moment…

Here is what I found for you :brain: Discord

Hello 0nederful, I’m sorry you’re facing issues with a grey screen after updating Needle to version 3.32.5. Here are a few troubleshooting steps you could follow:

  1. Check Console for Errors: Open the browser console where your project is running to check for any errors that might indicate what’s going wrong.

  2. Validate Project Files: Ensure that all project files were updated correctly and there are no missing or corrupted files.

  3. Examine Needle Engine Initialization: Review the code where the Needle Engine is initialized to confirm it is set up correctly, especially after the update.

  4. Review Networking and Rendering Settings: Look into the Networking and Renderer components settings if you are using them, as updates can sometimes change how these elements behave.

  5. Dependencies Validation: Make sure all related dependencies are met for the new version. Perhaps some dependency might be out-of-date and causing compatibility issues.

  6. Clear Cache: Sometimes, the browser may cache old files. Clear the cache and try running the project again.

  7. Documentation and Release Notes: Check the Needle Engine documentation and release notes for version 3.32.5 for any breaking changes or migration steps required for the update.

  8. Test with a Basic Scene: Try running a basic scene with minimal components to see if the problem persists. If it works, incrementally add components from your project to isolate the issue.

  9. Contact Support: If you have tried the above and the problem still persists, consider reaching out to Needle Engine support with detailed information about the issue.


Hi, which version did you last use for your old project? What’s your web project setup (which template did you use if any)? What are the errors in the console? You only show a few but they’re not the reason for the grey rendering.

Hey, I’m not sure which version I was on in my last project. I started multiple new projects using Shooting Range and Particle templates just now, same result.

This is the error on a fresh project with Particles template, using Unity 2022.3.14f, Needle Engine 3.32.7, node 20.10.0. I went through the project validation window and have everything checked there.

…so after taking a closer look at the WebXR error I tried a template that doesn’t use webXR (Fonts template) and it works fine. Anything that may’ve been done with that that could be causing this?

by user 507643794963824650

Hi youre using an alpha Version where we have made major changes to the webxr system. A samples release to match those changes will be made soon but hasnt been published yet.

Please use the latest stable release 3.31.x if you want to use samples until the new version of samples is available

That worked, thank you! Looking forward to checking out the changes

by user 507643794963824650