WebXR buttons not showing up in Sandbox

Just followed your youtube tutorial and deployed a sample sandbox to glitch! https://toothsome-surf-bubble.glitch.me/?room=quiet_bird_657

But, I don’t see the AR and VR options, and when testing with my quest pro I can’t use AR or VR capabilities.

Am I missing something obvious?

Original Post on Discord

by user 931365436187111505

found the FAQ! gonna try it out, Questions and Answers (FAQ) 💡 | Needle Engine Documentation

by user 931365436187111505

Hi! The link you shared above has the buttons for me. Make sure to use https: at the beginning of the URL (not http:)

Changed the channel name: WebXR buttons not showing up in Sandbox

Latest version adds a warning that popups at runtime when WebXR is used but the site is accessed from a non-secure connection

sorry guys, but still having issue, I am not able to see the AR or VR UI components when running locally either, just tried with a sample project and put that on glitch (see below), tested with https too

  1. can you confirm if you are able to see the buttons on this glitch url too? i’ve tried in multiple browers, edge, mozilla, google chrome and the oculus browser
  2. what browser works for you?.
    thanks for looking into this, this is the coolest tool, pretty new to unity with more xp in javascript and three.js

by user 931365436187111505


by user 931365436187111505

I see the buttons on this glitch. Just tried with my Pixel 4a in chrome

Yes, see them on desktop (VR) and phone (AR and VR) as well

Are you behind some kind of corporate firewall that intercepts https calls? Maybe you can try from mobile internet?

working off my home network, interesting just tried with goolge chrome on my phone w/o wifi and still no luck, had my brother try on completely different network and he can’t see as well , he tried of mac/windows machines

by user 931365436187111505

by user 931365436187111505

Very strange

Ah wait you’re using ios?

WebXR is not supported on iOS / safari. You can use the MozillaXR viewer on iOS for that tho

just download mozilla XR and the AR button appeared! i was trying with google chrome on my ios phone, in the above screenshot … but still not seeing on my desktop, what browser should I be using on my desktop, firefox?

by user 931365436187111505

wait its working with my oculus pro, you were right about the http vs https, sorry was testing in so many browers and missed this

by user 931365436187111505

i think we are good!

by user 931365436187111505

thanks guys!

by user 931365436187111505

The latest version added a warning about http access with webxr :slightly_smiling_face: