Quick Look AR Fail

I am using Needle to create an image-tracking ar app, the web integration is fantastic. However, I am having a bit of an issue when I try to export it as an AR web app for my IOS. I am aware that it is very limited for quick look, but it just straight up doesn’t work for me. The quick look button shows up on my page and when I tap it, nothing happens. Sometimes the quick look viewer would show up for a couple of frames, but then immediatly diapears.

I tried dowloading the sample project for the ar image-tracking, but that also didn’t work. I tried this on multiple IOS devices as well.

All of the samples on the needle sample page work until I download them.

What could be the issue?

I’m sorry, I couldn’t find a response. :cactus:

Hi, this indicates that there is an error in the generated usdz or you run out of memory. Do you have a link to your website that we can take a look at?

Hello, thank you fro the quick response, here is my site. Image Track

Ok, progress, the quick look viewer shows up now, it just gets stuck on load. Portfolio This is the new URL.

Somewhat more progress, If I use the sample, it tracks, but if I move the sample to my project root, it does the loading freeze thing.

I now put my scene in the sample and it is now frozen, I only changed the actual models.

Final update, I have narrowed down the issue to my custom shader. For whatever reason, the shader I have on my object is causing the freeze. I do kinda need the shader though, is there anyway to fix this?

Which shader did you add? Can you share it here?

Custom shaders can not yet be exported / Quicklook doesnt support shaders yet.

cc @herbst

I added a hologram shader I downloaded from the Brackeys tutorial. I did change it a bit, but it mostly stayed true to the original. I don’t know if I can upload it yet.

Ok if you do have a link we can look at what is causing quick look to close

It was the custom shader, the moment I turned it off, it worked. I just took a screen shot of what it looked like with the shader and applied that to a plane then had the plane face the camera, effectively making the same holographic sphere effect.

I’ll try to reproduce if a custom shader is causing this – it shouldn’t! (should just be exported without material or not at all, Apple doesn’t allow custom shaders on QuickLook for iOS yet).