PresencePlatformRoomTracking sample not working in vanilla project

glitch is now working -

by user 1081953198014734357

one thing i also notices all the objects in the scene looks like they have different shaders

by user 1081953198014734357

https://cream-daily-way.glitch.me/?room=smol_rabbit_771

by user 1081953198014734357

like the spheres are not shiny

by user 1081953198014734357

Ah cool, what did you change?

The spheres not being shiny is just a different skybox / reflection map if I’m not mistaken

Our update fixed it i think :wink:

yes. it fixed the glitch. now just waiting for this sample scene to fully work. skybox and colliders :slightly_smiling_face:

by user 1081953198014734357

OK, found the issue:
If you delete the Rigidbody component from the Disabled > Quad it should work again.
There seems to be a bug with that particular order of creating/disabling/enabling physics components right now which I logged internally.

Should be fixed in the next update :slightly_smiling_face:

I can confirm now that the colliders are working in my scene. will wait for the update to see the skybox.

by user 1081953198014734357

No need to wait - you can just assign one, e.g. the NeonSkybox or one of your choice :slightly_smiling_face:
image.png

ah cool. done.

by user 1081953198014734357

is there a way to turn the passthrough data into a skybox somehow for these reflections?

by user 1081953198014734357

Unfortunately not (at least not on Quest), Meta is very adamant they don’t want to give any raw camera acess. Best case would be that they implement the WebXR Lighting Estimation API (https://www.w3.org/TR/webxr-lighting-estimation-1/) but so far they haven’t. You also don’t get that data from Unity or elsewhere… so for nice-looking reflections in WebXR we usually use external HDRIs that kinda resemble typical interiors. Often this is good enough :slightly_smiling_face: