Npm Install not working on Linux resulting in missing files

This is strange 116 warn tarball tarball data for @needle-tools/engine@file:/home/exw/Documents/University/AR-VR/Project/Project/Library/PackageCache/com.needle.engine@2.55.2-pre/package~ (null) seems to be corrupted. Trying again.

ah its a wrong path?

this shows 2.54.0-pre

and not 2.55.2

i changed it to test with an older version i mention it at the beginning

by user 261850755751739393

i can update it if it is necessary

by user 261850755751739393

What exactly did you change?

Which package

just the exporter

by user 261850755751739393

There’s definitely a version mismatch now somewhere :thinking:

i can try it on an empty project and reinstall needle if it helps

by user 261850755751739393

Can you try downloading the samples from the repository here and open the project inside? GitHub - needle-tools/needle-engine-samples: Live: https://engine.needle.tools/samples 🌡 Needle Engine sample scenes - use as examples and as a reference for learning 😊

sure

by user 261850755751739393

your sample is made with unity 2020 will it be ok opening it with 2021

by user 261850755751739393

?

by user 261850755751739393

this is what it says. the project was just opened

by user 261850755751739393

Ah sorry you need to update the package there to the latest version (which adds a fix for the nvm error)

the needle engine exporter package?

by user 261850755751739393

Yes

this is what it says now


image.png

by user 261850755751739393