Needle Samples Build (Musical Instrument)

Hi there, we’re trying out needle tools for some use cases for our company. I tried the MusicalInstrument sample deploying it to a Glitch project. Unfortunately a lot of stuff doesn’t work correctly.

I can’t click on the sound-stones (but I can move the camera). I get an Uncaught TypeError: Cannot read properties of undefined (reading ‘set’) error in the console. Also in quicklook only around 4 of the stones play a sound, the others just animate. And on Android I can start a WebXR Session, but I can’t place it. My guess is that this might be the same error I get when I try to click the stones in the browser (I haven’t checked the console yet).

Glitch Project:
https://morning-brazen-cress.glitch.me/

Is there anything we have to consider about our setup? I’m on a Macbook Pro M1 on Unity 2021.3.34 (2022 didn’t build at all). And I’m using Chrome on Android.

Thanks a lot for any help!

Original Post on Discord

by user 313734732934283264

Hello there – we have an experimental AI bot :robot: that might be able to help you with your question. Would you like to try this out?

Hi which Needle Engine version are you using? this might be the same error as just reported here: Discord

I’ll look into it now

Version 3.32.9-exp

by user 313734732934283264

is there a stable version? (I just downloaded the one on the quickstart page)

by user 313734732934283264

3.31.1 is the latest stable

We’ll also need to update the samples package which will happen today or the next few days before you can use the samples with the latest alpha/exp versions

Oh I see. my bad. But also maybe put the link to the stable version in the getting started docs :smiling_face:

by user 313734732934283264

ah, it’s an auto-updater. I see now.

by user 313734732934283264

Yes - it’s planned, the installer that you download from that page is actually generated and always downloads the latest version. We dont have those cases often - but it’s something we want to add

ok version 3.31.1 fixed my issues. The sound-stones still don’t all work. But for me that’s not really important :+1: Thanks for your help!

by user 313734732934283264

The error here is now be fixed in alpha 11 Uncaught TypeError: Cannot read properties of undefined (reading 'set')

Regarding this: does it happen in Quicklook when you click fast / use multitouch? We tried using the latest version and that’s one of the issues we found (clicking many fast doesnt play sounds - whereas “normal” clicking/tapping worked)

ah, actually now that I’m checking it again. It also happens in desktop browser. (Brave)
You can check it here: https://morning-brazen-cress.glitch.me/

by user 313734732934283264

Would be good to show the current version the sample was made with. :slightly_smiling_face:

by user 726710936823398470

You can see that in the console log (if you don’t have a license), in the HTML header and on the <needle-engine> web component as well as via the static variables __NEEDLE_ENGINE_VERSION__

Hello @pixlhero this doesnt happen on the latest version - altough the first click only triggers loading the audio which results in it not playing immediately depending on network speed (the audio should be preloaded in this case - i will make a note for that) https://lush-highfalutin-handspring.glitch.me/

you mean in the new experimental releases?

by user 313734732934283264

Yes