I have a Puzzling Issue with Models

The Unity asset of teenager models works when I build/export locally (and put each teen model in its own empty gameObject). Yet, after publishing to either Glitch or by FTP to my personal server host, viewing the scene page doesn’t completely load. It runs through the sceneRoot.glb progress bar to completion, then remains a black screen with this error (image attached) in the browser console.

You can view the page here: https://quark-rattle-knot.glitch.me

If it was too large, I wouldn’t think it would work locally.

I’m not sure what to try next.

I’ve updated the packages to the latest version. I’ve updated toktx to verson 4.0 (but not 4.1).

The export & build succeeded with no errors, per log:

Uploading 132.7 mb (uncompressed: 243.1 mb) to https://quark-rattle-knot.glitch.me
Endpoint: https://quark-rattle-knot.glitch.me

Successfully deployed to https://quark-rattle-knot.glitch.me in 00:56
image.png


Original Post on Discord

by user 581381221087445033

Strange. The Glitch site seems to work now. But I still have the error here:

by user 581381221087445033

Stranger still. Seems to work for FTP now:

by user 581381221087445033

132.7 MB is most likely too large for the Glitch instance (we’ve seen random issues starting at ~50 MB but after optimizations on our end we got it to ~100 MB)

That being said it looks like the deployment itself worked for you - so the file size is not an issue -
but according to the error DRACO decoding fails (so some buffers would not be complete)

Locally, there’s no such thing as “too large” (or well, what you have there certainly isn’t) - some clients have 2 Gigabytes of (uncompressed) data running in browsers locally

Woah, there’s a ton of KHR_animation_pointer errors in the console for that page.

But: I also don’t get the DRACO errors. Maybe it was just a caching issue?

im getting them here too: Basic Physics. The other link works as far as I can tell

The .glb also fails in Babylon and other three viewers, looks like a genuine error with DRACO encoding…

Because it didn’t work during a day of development (no matter what I changed) then worked after no changes, it kind of sounds like a buffering issue on (both?) hosting providers. I’d drop it for now. I’ll let you know if it pops up again while DRACO encoding anything else. I’m now glad to know of the Glitch performance hit that could happen between ~50 MB & ~100 MB. I’ll watch for that. It might be good to document that for others.

by user 581381221087445033

How do you usually check for distro size? Just look at the .glb size or all the files in the folder together?

by user 581381221087445033

We haven’t found strong numbers for what works/doesn’t work on Glitch unfortunately… I saw 100MB deploys succeed and 30MB deploys fail so far. But yes, we should document those rough limits better for sure

Regarding distro size, there’s console logs for the total file size of various file types and the total, both for compressed and uncompressed.

We plan on turning that into some nice window with stats at some point - for now it’s text :slightly_smiling_face: