How to configure skybox compression?

Using a huge 7k source skybox cubemap for a scene and in the local server/production builds the skybox looks very compressed still. I used Needle texture import settings to set compression to none, size to 8k but it still looks as compressed?

Original Post on Discord

by user 103054507105067008

If you add a Skybox Export Settings component you can set the max resolution.

Generally it’s definitely not recommended to have a 8k texture for anything, you’ll crash weaker devices with certainty

Thanks, and of course, just went max res to see if it was something in texture import settings

by user 103054507105067008

Yeah we do kind of safeguard by default against you using an 8k skybox :wink: that’s gonna be a couple hundred megabytes