Editor Sync stopped working

Not sure when the editor syncing stopped working but I think it happened after I updated the Needle Engine package. Have tried re-installs, soft restarts etc. Any advice on this?
Unity 2022.3.9
Needle Engine 3.31.0

Original Post on Discord

by user 427134081860501507

Hello there – we have an experimental AI bot :robot: that might be able to help you with your question. Would you like to try this out?

@Snorulf do you have compression in the exportinfo component enabled? Can you try disabling it ?

When the glb gets compressed the editor sync extension gets removed - which contaisn the data necessary for syncing to unity (but only for unity which is why it gets removed) - so you can not have compression (for local dev) + editor sync enabled at the same time.

I’ll make a task to make it more clear in Unity that this is the case

@Snorulf it’s actually been two issues

  • disable AutoCompress in ExportInfo
  • I’ll make an update to the EditorSync package to 2.0.3 (it should auto update when you do a clean install, will be published in a few minutes)

Ok thanks.
Disabled AutoCompress but that didn’t help. Will try with an updated the sync package and get back to you tomorrow.

by user 427134081860501507

yes, both changes need to be applied (the update as well as disabled autocompression)

Did a clean install but EditorSync is still on 2.0.1-beta.
Do I need to update Needle Engine as well to get the 2.0.3 version? Engine is still on 3.31.0 and it looks like all the versions after that are experimental.

by user 427134081860501507

Please update to 3.31.1 Discord

Great, I could not find it in the package manger

by user 427134081860501507

Oh ? Let me check.

Sorry seems like there was an error during publish and I missed it - will publish it right away

It should show up now (Needle: Package Registry)

Works now :tada:
Thanks @marcel :cactus: :star:

by user 427134081860501507