Deploy to FTP

Does your server support gzipped files? If not turn of compression in the vite.config.js and upload again (files should not end with .gz then)

You can find more info in the docs

Sorry have to sleep now :sweat_smile:

by user 823113958117474354

What I can do next step ?

by user 823113958117474354

@marcel :cactus: Okay I got it. I have deployed successfully

by user 823113958117474354

Great. Could you explain what you did or changed (so someone else reading this thread might learn from it)?

Before upload file dist in sever you see this error after uploading your project make sure you do not upload a gzipped index.html. You can disable gzip compression in vite.config.js in your Needle web project folder. Just remove the line with viteCompression({ deleteOriginFile: true }). The build your project again and upload to itch.

by user 823113958117474354

Ah youre uploading to itch.io?

If you upload to itch.io you can also use this component to create a zip that you then can just upload
unknown.png

I upload my sever test

by user 823113958117474354