Custom font preventing build

At one point i had a custom font working. I presume i changed the package version or something and from that onwards… it’s erroring out on build.

Original Post on Discord

That’s strange, can you try updating?

That code didnt change since it was originally published :thinking:

Ok got the same error for some reason - I’ll check

Is it blocking the build for you?

Looks like it works but fontgen is broken (i have fixed it locally)

not sure why it stopped working / errors now

works again locally

can push a hotfix if its blocking

Perhaps it’s not stopping the build per say, maybe i have other errors. I’m bit lost on this one. I had my old working copy behaving bit differently then the one i just cloned.

I’ll double check if everything is ok, but it was X days ago when it was working alright.

Under the hood its now using glTF transform v2 - I think that should work with toktx 4.x too (at least in all projects I tried) maybe @herbst🌵 knows more?

Which texture is failing?

Is it smaller than 4pixel?

Maybe thats the emitted white stup texture :thinking:

It’s failing on our favorite shadow texture :stuck_out_tongue:

haha why :thinking: its the same texture I tested with :smile:

which toktx version do you have installed? toktx --version

toktx v4.1.0-rc3~4

i’ll do a test with 4.0.0