Voip not connecting to scene when joining with XR Headset

I am using the default Voip Component. If I join the scene using a desktop browser or a phone, the voice chat works as intended. When a user joins, other users receive a console log containing a list of the joiner’s connected audio devices. But if I join using a vr headset (tested using a Meta Quest 2) I am not able to hear other users, and they are not able to hear me. The console log containing the list of audio devices is also not sent. I am asked for permission to use the headset microphone, but the vr browser doesn’t give an indication that the microphone has been activated. Typically if a web page uses the headset microphone, a microphone icon appears in red on the address bar. Here the microphone icon appears, but it is white as if to indicate that the microphone isn’t active.

Am I missing something which adds the voice chat for the headset user? I have tried attaching the Voip Component to a couple of different objects in my scene, such as the vr avatar, and an empty which contained only the Voip Component and was parented only by the scene. I didn’t notice a difference in the voice chat performance.

Original Post on Discord

by user 229373651894534144

Hi, it doesnt matter where the VOIP component is attached. This sounds that your quest browser does not have the permissions it requires to access the microphone?

To verify on a different site you can try https://castle.needle.tools/
and https://webcammictest.com/check-mic.html

Both of those sites are able to access my headset microphone, so that must be the issue. When I first join my glitch I’m asked for permission to use the microphone and I press “allow”. So I’m not sure where in the process I’ve messed up

by user 229373651894534144

Ok that’s odd. The VOIP component hasnt changed in a long time - funnily enough I was just working on upgrading it today. I’ll test it here again on my quest and send you a link later to try

You can try it here (just tested in VR on Quest 2 + Desktop + Android and that worked)

That link works for me too

by user 229373651894534144

Ok great. One of the next versions will have the updated voip component (maybe included in the update tomorrow or on friday)

Thanks, I’ll keep an eye out for it

by user 229373651894534144

Hi @Drakkama sorry for the late ping - VOIP has been updated in one of the most recent versions

Please let me know if that fixes the issue for you!

Thank you for letting me know, the new version of the VoIP looks very useful. I was testing out my scene there, and I think the issue is fixed. It might have had something to do with my browser settings instead however. I reset my meta browser’s cache and the next time I loaded my scene the voice chat functioned properly. I’ve noticed that pressing the microphone icon on the browser’s address bar when the microphone is active will bring up a menu with an option to disable it. But if the microphone has been disabled, that menu doesn’t appear. So it’s possible at some point that I disabled the microphone and couldn’t find the way to enable it again. Thank you for your help though, having the sample scenes you sent me to mess around with helped me to figure it out

by user 229373651894534144

Ok cool! Good to hear! I think the update is still worth making if you continue working with it now because it improves the whole voip and screensharing networking and will be the bases for integrating voip with e.g. screensharing and networking videostreams as well :slightly_smiling_face:

Thanks, I’ll definitely switch over to the new stuff. I like the new options it has I think they’ll be useful to me. Thank you again

by user 229373651894534144

how do you know if this works? it prompted me to allow microphone and i accepted, but then dont see anything else happening in log or anywhere when i talk

by user 352282921056468993

also, does voip require networking component? in my local project, it doesnt even prompt to allow mic. all i did was create empty object and add voip to it

im not trying to talk to other people multiplayer, im trying to allow users to talk to 3D avatar on the screen

by user 352282921056468993

ahh okay, i added SyncedRoom component in and now it prompts me to allow mic - so i guess voip does require networking

by user 352282921056468993

Yes voip is used for voice communication over a network, like teamspeak or when you do a discord call.