Unable to play videos from Videoplayer on Safari. Autoplay settings might be the issue

I have a videoplayer which works on every browser except Safari. I checked around and found out that Safari has a settings which stops autoplay from videos with audio. A user interaction is required but whatever i do from Unity doesn’t work on Safari. Do you have any suggestion to solve this issue? If i mute the video the player works, but i’m not in the situation where i can extract the audio and sync it

Original Post on Discord

by user 191193824372981760

Hey, are you using the VideoPlayer component?
Audio is generally not allowed to be played before any user interaction - the AudioSources do respect that and I was thinking Video too but perhaps that’s a bug or regression where it’s not.

Which version of Needle Engine are you using?

Hi @probobbo do you have some more information about your usecase? What format is the video in?

oh i forgot to update this, i solved the issue by adding a muted videoplayer with “play on awake” enabled in the scene

by user 191193824372981760

so when i tap on the UI, safari starts playing videos

by user 191193824372981760

the muted player is hidden to the user of course

by user 191193824372981760

Bit strange that this fixes it. Would you be able to still make a bug report from a scene that doesn’t work for you? I wasn’t able to reproduce it here, our intnernal logic should make things “just work”