'The application can’t be opened. - 50' error when building

Everytime I try to build, this error comes up. In the console it says, “ERR: mkdir: Permission denied”

Building to glitch does work though.

I’m I doing something wrong?

Original Post on Discord

by user 264626421891072001

Hello there – we have an experimental AI bot :robot: that might be able to help you with your question. Would you like to try this out?

How it works:
Reply to the messages of the bot that end with a thread_id to interact with it and ask follow-up questions. You can also mention the bot directly in this channel to get help.

Help requested: please wait a moment…

Here is what I found for you :brain: Discord

Hello Brendanluu,

The error message “ERR: mkdir: Permission denied” indicates that the process trying to create a directory does not have the necessary permissions to do so. This can happen in various circumstances, for example when trying to write to a read-only file system, to a directory where the user does not have write permissions, or when security policies prevent the creation of directories.

If building to Glitch works but you face this issue with another destination, it suggests that the issue might be with the specific permissions of the folder or the environment where you are trying to build the project.

Here are a few steps you can take to troubleshoot and resolve the issue:

  1. Check the permissions of the directory you are trying to build into.
  2. Make sure that you have write access to that directory.
  3. If you are using an IDE like Visual Studio Code, make sure it is run with the necessary privileges.
  4. Double-check the build path specified in the build settings to ensure it is correct and writable.
  5. If working in a restricted environment (like a corporate or academic network), check if there are any policies that restrict directory creation.

Let me know if you need guidance on how to check or modify directory permissions so I can further assist you.

1 messages left GPT 4
Thanks for your feedback!

@brendanluu which Needle version are you on? I remember that issue popped up a while ago on Mac specifically but should have been fixed already

I think this happens only the first time - when you click “Ok” the terminal should open with the local server