Problems running quick action preview

Hi :wave: :slightly_smiling_face:

Since the last couple of updates I find I’m unable to run the preview.

Whenever I hit the ‘Play’ or ‘Start Server’ buttons I get a notification saying “Error: port 3000 is already in use” along with “Server is not responding - it could mean that another application is already running on port 3000… etc etc” .

I’ve run ‘npm start’ in the requisite directory, as suggested in console, but sadly that didn’t help… plus I’ve also run ‘lsof -i tcp:3000’ and successfully killed anything that’s running (just Unity and node were listed), then reopened the project and tried again, but no luck. I still get the ‘port in use’ problem.

I’ve even shut down and rebooted the computer, and run disk utilities… still no joy.

Any help or advice will be gratefully received :slightly_smiling_face:

PS: I’m on Mac OS Ventura 13.4 … and am currently using Needle v 3.5.9-pre

Original Post on Discord

by user 908977119781060648

That’s strange. When you visit the local IP in the browser, does it still work despite the logged error?

And: which Unity version are you on?

Hi @herbst​:cactus: and many thanks for responding :slightly_smiling_face:

I’ve tried running stuff using Unity 2021.3.2f1 (the original version used for the project) and also 2022.2.2f1, to see if that made any difference - but sadly not.

If I clear the browser cache several times I’m ‘sometimes’ able to get the local IP to run the preview as intended… but it doesn’t happen every time and seems fairly random.

by user 908977119781060648

I’m using Chrome v 113.0.5672.126 (Official Build) (x86_64), BTW.

by user 908977119781060648

Hi Frannie, i have an idea what might be causing this. Will try to verify later and make an update

Awesome. Huge thanks!

by user 908977119781060648

No rush :slightly_smiling_face:

by user 908977119781060648

Hi Frannie, can you try with the latest update?

Hi @marcel :cactus: … apols for the lengthy delay in replying but I’m having trouble accessing the update.

Despite several refreshes (and a restart of Unity) the Package Manager is still only offering v 3.5.9-pre, with the most recent update cited as being May 20, 14.24 as opposed to your latest update at 13.11 today.

by user 908977119781060648

Oh there has been a typo in the version string, I’m sorry

Publishing right now again

It should now be available

:slightly_smiling_face: will try now…

by user 908977119781060648

WooHoo! Absolutely perfect. HUGE thanks!!! :star_struck:

by user 908977119781060648

thank_you.mp4

by user 908977119781060648