My scripts doesn't work anymore after update

Hello,

I’m using the react template which worked very well but after update, my getContext doesn’t work anymore to use my scripts from my React UI.

How could I solved that ?

Original Post on Discord

by user 224464722878005248

Hi @AeistDesmos does the scene load for you?

Not at all

by user 224464722878005248

by user 224464722878005248

That’s my only warning

by user 224464722878005248

Ok thats fine. Its very likely because of a recent change in the js codegen (if you look in /src/generated/gen.js). Will have to check the react template later.

Sorry i missed that

Okay, got panicked because for a simple reload my work came from to very good to nothing appeared ^^’

by user 224464722878005248

Don’t hesitate to let me know when the outcome is fixed.
Is there any way to go back to a previous version where the template react works?

by user 224464722878005248

Yes you just need to downgrade to your previous version using unity’s package manager (Window/PackageManager) for example (or discard the version change in git!!)

I went back to version 2.60.4-pre and it works again, I didn’t think I had to go back so far ^^’

by user 224464722878005248

The change i was referring to landed in 2.65 tho

I tried with the 2.62 version but it wasn’t working :confused:

by user 224464722878005248

Let me know when getContext works perfectly in the react template and I’ll test it on my project to see if it’s the 1.65 change that is causing this problem.

by user 224464722878005248

Just to clarify: you refer to the r3f template or the react template?

Hi @AeistDesmos this is fixed in the next version

I will try that, thanks

by user 224464722878005248

by user 224464722878005248

Next version :slightly_smiling_face:

Oh, the next version not released ^^’ ok

by user 224464722878005248