Missing files when I try to run locally

Hi guys,
When I try to test the app locally it gives me an issue mentioning missing files. Even if I try the repository that other people have, the issue only happens to me, since other people don’t have the files in the project as well.
I already set up the needle and the project several times but the problem persists.

Can somebody help me?

Original Post on Discord

by user 433370857134358528

Does the file youre trying to import exist in assets/imgs/user.svg ?

The file as well as the folder don´t exist in the project. We all use the same repository with the same stuff. But only me got this missing files error.
Wouldn’t this folder be created only when you click “install” on the needle’s “export info” tab?

by user 433370857134358528

It depends on your configuration. By default assets will be created on exporting a glb if it doesnt exist yet.

On install it wont create that folder

That assets folder is by default also excluded from sourcecontrol to avoid checking in exported glb files. But if your team adds either files manually or through some other process they might be missing on your end if you just install and start the server.

One option would be to modify the gitignore that is inside the web project for example.
Or better: talk to the person who added the user.svg there and figure out if they added it manually or through some custom other automation

Thanks @marcel :cactus: for the help :smiley:

by user 433370857134358528