Autocomplete in TS

weird and maybe stupid question. Autocomplete was working fine for days and then randomly stopped working. Any ideas why?

My best guesses:

  1. i updated to latest Needle

What i tried

  1. deleting node_modules and letting it reinstall

Original Post on Discord

by user 352282921056468993

like it wont autocomplete because it cant find the module. But the module is there and the scripts do indeed work, despite the errors in IDE

by user 352282921056468993

try running a clean install and reopen vs code

i deleted locally and repulled from repo - is that what you meant? no good

by user 352282921056468993

If you hover over this button while holding alt

that’s what i mean by “clean install”

But yeah, this doesn’t sound correct :confused:

What Node version are you running?

i had the wrong version of Node. Fixed that and then did clean install how you said and it worked! thank you!

by user 352282921056468993

Lovely :+1: glad that you are back up to speed :stuck_out_tongue: