ReferenceError Cannot access 'Behaviour' before initialization

First off thank you for this amazing tool!

I got it to work but I can’t get the workflow working as shown in the YT tutorial.

All works fine until this moment in the video

The live update workflow gives an error in the browser of

ReferenceError: Cannot access 'Behaviour' before initialization

Only way around it is to click the “Start Server” button in the Needle Engine tool over and over until it finally works. Nothing works to fix it and I don’t ever see realtime live updates as shown in the video.

Current workflow:

  1. Start server from Needle Export object via the Inspector
  2. Move and scale the cactus
  3. Save the project
  4. Browser refreshes and then goes white screen with the error above.

I’ve tried many things but can’t get past that part.

Advice?

Original Post on Discord

by user 412630148001824768

Hey sorry about that. It’s a known issue and we’re looking into how to fix it.

When it happens for me stopping the server and clicking play again usually fixes it - from your description it sounds like you tried that several times but it took more attempts until it worked?

Yeah it’s pretty random. I eventually get it to work after different variations of restarting the server.

by user 412630148001824768

Changed the channel name: ReferenceError Cannot access ‘Behaviour’ before initialization

Any other suggestions? This started happening and nothing I’ve tried has fixed it.

by user 289864542349950978

Do you remember which version you used previously?

This is the only version I’ve tried
Exporter 2.35.0-pre
Runtime 2.31.0-pre

by user 289864542349950978

Can you try updating to 2.35.5-pre and see if it still happens?

Sure

by user 289864542349950978

It works! Thanks

by user 289864542349950978

Great!

Let me know if it happens again

Updating to 2.35.5-pre fixed the error for me. Thank you @marcel :cactus: !

by user 412630148001824768

Awesome :slightly_smiling_face:

It just happened again, unfortunately

by user 289864542349950978

Does this help?

I tried a few times, but no

by user 289864542349950978

Can you try if stopping the server, clicking install and then starting again helps?

Which OS and node version are you on?

That may have worked just now, thought I’m not sure what order I clicked things
Windows 11, node 16.18.0

by user 289864542349950978