Collaboration Sandbox Template is missing prefabs

Hi… I’ve just tried to begin a new test project and when I import the latest version of Needle Tools and attempt to create a collab sandbox I get an almost completely empty scene and a bunch of error notifications.

I tried a few super-simple potential fixes. Namely I deleted the project, started afresh, reset all of Unity’s packages (just to be on the safe side), imported the latest Needle Tools again… but no matter what I try I keep getting the same outcome :grimacing:

I couldn’t see a way to zip and send the project via feedback; so instead I’ve attached a screen shot of what I get shown.

Hope you can help :slightly_smiling_face:

PS: I’m on Mac OS Ventura 13.1 - Unity 2021.3 16f1

Original Post on Discord

by user 908977119781060648

The prefabs are missing? Thats weird, we didnt touch them or the collab template for weeks. Ill try if it reproduces later.
Can you try if reimporting the Needle Engine Exporter package changes anything?

Hi @marcel :cactus: … I’m afraid I’ve already tried reimporting and it didn’t make any difference.

by user 908977119781060648

Ok i hope it reproduces. But to understand correctly it mainly means that the prefab models dont import, so when you play the scene is empty (skybox only?) But it runs in the local server? In which case you could still work with your own models/materials etc

Sadly not, as I don’t have enough expertise (or experience with Unity) to work around not being able to build the project. The ‘export’ properties currently look like this (attached).

by user 908977119781060648

There’s no mad panic re: any of this, by the way. I’m not on a work deadline etc as it was simply another test.

I’ll be grateful for any advice at whatever point in time that you manage to have a look into the issue, but no rush :slightly_smiling_face:

by user 908977119781060648

What happens if you delete the content gameobject and press play?

Ah, sorry… can’t try that as I’ve just this minute deleted everything and am downloading Unity 2022.2 2f1 to see if that helps. The download’s taking a while but I’ll feedback as soon as I’m able to give a new project a try.

by user 908977119781060648

Ok, if its just missing prefabs that you dont need its no problem and just a bug in Unity with those imports. Still something to fix but you should be able to work as usual

Thanks, and duly noted :slightly_smiling_face::+1: Plus, I’ll shout back here when I’ve got the new version of Unity up and running and let you know if it’s made a difference.

by user 908977119781060648

Changed the channel name: Collaboration Sandbox Template is missing prefabs

Okay, so, sadly my ‘grand’ plan (i.e. deleting the test projects, uninstalling Unity and then installing the latest version (2022.2 2f1) hasn’t changed matters.

Nor am I able to simply continue despite the missing prefabs as regrettably I don’t have the expertise to know what to do about all the missing scripts (each and every instance of a script in the project displays the error message highlighted in this screen shot).

So, unfortunately I’m rather stuck for the time being.

by user 908977119781060648

ExportInfo is missing? oO

Do you get compiler errors in the console?

ExportInfo shows up in the dropdown menu… but if I select it, it doesn’t make any difference. The error message still exists.

by user 908977119781060648

The console shows this…

by user 908977119781060648

This is a fresh project in 2022 and you just installed the Exporter package?

Are there any other errors except the missing prefab error (Prefab instance)?

Would they be anywhere other than the console? Am I looking for them in the right/wrong place?

by user 908977119781060648

They would be in the console